INT 21h

Hi, I am Vladimir Smagin, SysAdmin and Kaptain. Telegram Email / GIT / RSS / GPG

Mikrotik: unicode symbols in wifi name (ssid)

№ 11507 В разделе Sysadmin от December 20th, 2021,
В подшивках:

You can’t enter unicode symbols directly in wifi name field in winbox, but it can be done with terminal. This page generates command string with some unicode symbols https://r-1.ch/mikrotik-unicode-ssid-generator.php.

For example, you can use popular meme about 5G towers and covid19 “📡 COVID19 5G TEST TOWER ☣”

Нет комментариев »

MQTT periodic messages on Microtik

№ 11399 В разделе Sysadmin от December 19th, 2021,
В подшивках: ,

Activate IoT package

Add your MQTT

Create new script

:local broker "home"
:local topic "/router"
:put ("[*] Gathering system info...")
:local cpuLoad [/system resource get cpu-load]
:local freeMemory [/system resource get free-memory]
:local usedMemory ([/system resource get total-memory] - $freeMemory)
:local rosVersion [/system package get value-name=version \
    [/system package find where name ~ "^routeros"]]
:local model [/system routerboard get value-name=model]
:local serialNumber [/system routerboard get value-name=serial-number]
:local upTime [/system resource get uptime]

:local message \
    "{\"model\":\"$model\",\
                \"sn\":\"$serialNumber\",\
                \"ros\":\"$rosVersion\",\
                \"cpu\":$cpuLoad,\
                \"umem\":$usedMemory,\
                \"fmem\":$freeMemory,\
                \"uptime\":\"$upTime\"}"

:log info "$message";
:put ("[*] Total message size: $[:len $message] bytes")
:put ("[*] Sending message to MQTT broker...")
/iot mqtt publish broker=$broker topic=$topic message=$message
:put ("[*] Done")

Now create new schedule

Now check out your MQTT messages

Нет комментариев »

Wireguard VPN between Mikrotik and my android phone (without changing firmware to openwrt!)

№ 11088 В разделе Sysadmin от September 1st, 2020,
В подшивках: ,

At last, Mikrotik released version 7.1b with Wireguard support! YES!

You can upgrade your device now by switching to development branch.

So, create new wireguard interface, keys and set port.

Assign IP address to your new interface

[admin@MikroTik] > /ip address
[admin@MikroTik] /ip/address> add address=10.50.20.1/24 interface=wgvpn

On your mobile phone install Wireguard client and make same steps, assign IP address in same subnet, use public key of your Mikrotik.

Now on Mikrotik create new peer with public key of your phone

Check it

[admin@MikroTik] /ip/address> /tool/ping 10.50.20.4
  SEQ HOST                                     SIZE TTL TIME  STATUS             
    0 10.50.20.4                                 56  64 126ms
    1 10.50.20.4                                 56  64 52ms 
    2 10.50.20.4                                 56  64 80ms 
    sent=3 received=3 packet-loss=0% min-rtt=52ms avg-rtt=86ms max-rtt=126ms 

Allow connections

In absolutely same way you can set up private network on your computer.

Нет комментариев »

Проброс портов и настройка NAT в Mikrotik

№ 9756. В разделе Sysadmin от February 24th, 2019

В подшивках:

Яндекс.Метрика

Fortune cookie: Spam del giorno: Ad attivo i servizi on-line e nuovi con ${SiteName} per favore completano il Suo ${SiteName} conto on-line